User Tools

Site Tools


en:public

Information

IQUALIF is a data scraping software that is used to extract large amounts of public data including addresses, phone numbers, and email information from yellow and white page directories. IQUALIF has separate downloadable software versions that can let you perform scraping on yellow and white page directories separately. IQUALIF is available in 16 international languages for software users to easily launch applications in their native languages.

Purpose

IQUALIF is intended to provide authentic Persons and Businesses contact data for research, e-commerce, sales, and other commercial purposes. It is an effective way to expand business prospects on B2B and B2C levels.

Download

To download a free trial version of IQUALIF, click on https://www.iqualif.com/en/yellow-data-pages-extractor-white-extract-people-business-download-scrapper. Search for your country and choose IQUALIF version (persons or businesses). Click on the Download button to get the executable file.

You can download the licensed version directly by clicking on https://www.iqualif.com/en/buy. Select your region and country. Choose your preferred version and click Download.


Install

Windows

After you have downloaded the software from the website, click .exe installer to run the setup. Complete the installation steps and check your desktop for a newly created IQUALIF icon. Double-click the icon to launch the application

  1. Install the software from downloaded .exe as an ordinary windows app.
  2. You can run software from your desktop.

If you prefer you can watch the video here: https://www.youtube.com/watch?v=jDT745KFcBY

MAC

Double-click the .pkg file that you have downloaded to your Mac operating system. Complete the installation and open the Finder app. Locate the application folder and drag your IQUALIF to the application folder. Double-click the application to start IQUALIF.

  1. Install the software from downloaded .pkg as an ordinary mac app (if a warning appears, right-click and click on open).
  2. You can run software from your Application folder.

Linux

unzip the .zip that you have downloaded to your Linux. Navigate to the extracted folder. Install the package through the command line using the command

apt-get install ${packagename}

Or

unzip ${packagename}.zip
sudo java -jar ${packagename}/l.jar

See also Troubleshooting


Interface layout

  1. List Modeimg
    1. Search progressimg
  2. Browser Modeimg
    1. Search progressimg
  3. Manual Modeimg
    1. Search progressimg
  4. Import file (Import list)img
    1. Search progressimg

Start the search

IQUALIF lets you search contacts through its main application interface. You can select source directory from the dropdown menu to collect data for persons or businesses and then apply search of your choice img There are five modes of data extraction searches; List Search, Semi-Auto Search, Manual Search, Browser Search, and Search with Imported file

List Mode

List mode search is effective in gathering large amounts of contacts with minimal clicks. To start a search in list mode

  1. Select list mode
  2. Select province from left most window
  3. Select your desired City from the middle window
  4. After the selection of province and city select the street(s) from the right window
  5. Click Start button img from top to start data extraction. Whenever a new search is started, the application throws a pop message “Add to Last Search?”. Click Yes if you want to append data to previously queried results or click No if you want to keep new search results in a separate file. You can check the search progress in the lower pane of the screen.
  6. When the search is 100% complete, export your data by clicking on the Export Results buttonimg. Export results can be saved in .csv, .xls and .xlsx formats. You can pause the search anytime by clicking on the Pause buttonimg and resume it later

img

Browser Mode

Browser mode helps to search contacts directly from yellow/white page websites.

  1. Select Browser mode
  2. Type your query in the website search bar and press Enter
  3. Once the records are loaded by the website, click on img button to import results in IQUALIF
  4. Once the import is complete, click on img button to export contacts to your device

img

Semi-Auto Mode

Semi-auto searches search contact data of a specific street only. To start a semi-auto search

  1. Select Semi-Auto mode
  2. Select province from the left window
  3. Select your desired City from the middle window
  4. Type street name in the right window
  5. Start the search
  6. Export data to your device in the desired format

img

Manual Mode

Manual mode search allows accessing contacts by manually entering your desired criteria and location

  1. Select Manual mode from the list
  2. To extract person data enter Postcode, City, and Street in the screen with a pre-selected white page option from the directory. For business data, enter Department and Street name on the screen.
  3. Click on img button to start the search.
  4. Click on the export data option once the search is complete.

img

From Imported File

To search the directory with the imported file you need to have a .csv file with required columns names in the following format img Press CTRL+I from the keyboard or Go to the File tab and select Import File from the list to open the import file screen img Click on the Browse button on the import screen to choose your CSV file from the device. Select your file and click Open img The import file utility will populate your columns in the grid as shown below img Match file columns with table columns and click Start. On successful import, a pop-up message will appear “Import is done” img Click on img button from top menu. A pop-up message will appear asking if you want to start a new search img Click the New search from file option. The application will start the search with imported columns. Wait till the search is 100% complete and export your data in the desired format


License

License screen provides details about the current activation status of your product

To open, at the top of the screen, click on the menu ?>License. Click on the buy button to get access to an online form, which will allow you to select your product features and enter the necessary billing information.

This is a video explaining how to check which version of the software you are running: https://www.youtube.com/watch?v=gAGNEdbKS5Y

Activate a Free Trial

After installation of the trial version, go to the license tab in ? menu and click on Activate 3-day Trial for free. Click OK. A pop-up message will appear showing “Product has been activated” img

Activate a License

You can get the license activation key by buying the software from an application or visiting the website https://www.iqualif.com/en/. Click on img button to buy the product directly from the application

To activate the license open the license screen from the ? menu License. Select the Activate a license option and enter your license Key. To go faster, we advise to copy-paste the license, copy the license including -, click in the first rectangle and paste by pressing CTRL+V Click OK to complete activation. A pop-up message will appear on successful activation img

Get a License

You can get IQUALIF license by buying the software from the website or by clicking on imgfrom the application

Select the product and add it to your shopping cart. Proceed to checkout to provide your general information and card details. You will receive your license activation key via email within one hour of order confirmation. Payment can be done online through the website, Debit/Credit Card, Bitcoin, and PayPal. For Bank Transfer payments, contact our sales department through the online contact form to get further details.


Progress

This is a progress bar that indicates the status of the current search

  1. Pages left: shows the number of the main search in the queue (e.g. restaurant in Ontario)
  2. Next pages left: shows how many next pages are in a queue (e.g. restaurant in Ontario is displayed on 7 pages)
  3. Detail pages left: shows how many pages with contact details with full info are there (e.g. profile page)

img


Settings

To open, at the top of the screen, click on the menu File>Settings

Language

This setting allows you to translate IQUALIF into one of the available languages from the dropdown. IQUALIF can be translated into 14 languages including French, Dutch, Spanish, Italian, Arabic, Portuguese, Turkish, Hindi, Korean and Japanese.

Extract more detail

This setting allows you to get more information, from the details page of the company. When disabled, the search is quicker

Extract more mail data

This setting1) allows selecting if you wish to search for emails too. When disabled, the search is quicker

Delete Duplicate

This setting will check for duplicate records with the same phone numbers and delete repeated data from exported results

Hide Professionals

You can enable the Hide2) checkbox to eliminate professional records from every search. This setting will be applicable to both yellow and white page searches

Advanced

Update settings

You can set the frequency for automatic database updates in this section. Select 1 day, 2 days, 7 day, or 30 days from the list or click on Check for Updates to update whenever it is convenient img

Manual Update

This video will show you how to manually update your software: https://www.youtube.com/watch?v=X1Vlcpm2RYE&t=10s

Export to Server Settings

You can export your search data to a server by adding server credentials in this section. Enter MySQL database connection details

  1. Host IP
  2. Database
  3. User
  4. Password

Click on the Test button to check if the connection is established. You will receive the following error message if the connection is not established img

Server Mode (Master/Slave)

You can run your application in server mode and establish a master-slave connection with any other machine for carrying out search functions. To create one such connection, enter Password and Port of slave machine. The setting requires restart on every ON and OFF

Enable IP obfuscation

You may desire to obfuscate your IP address due to global privacy regulations or blocking. To apply the setting click on the Browse button to import a .csv proxy list. The proxy list should be in the following format

10.0.0.1:3126 or socks;10.0.0.1:3126;user;pass

Click the Tick to Enable checkbox to obfuscate IP


Dashboard

To open, at the top of the screen, click on the menu File>Dashboard

Dashboard screen help to start two parallel remote searches on multiple machines concurrently. You can monitor the progress of your searches from one machine. To add a new Machine, enter IP address, Port address, Password and click Add. You can select multiple machines to delete or refresh data simultaneously.


About

To open, at the top of the screen, click on the menu ?>About

About screen provide information about IQUALIF version name, release number system, your system OS details, and IQUALIF specs (Speed/Page per hour/Contacts per hour)

IQUALIF Canada 41 White v 1.098.99.151
Windows 8.1 (x86,32)(1/155/178)

Uninstall

Windows

Go to the Control panel and click on Uninstall a Program or Feature. Find IQUALIF and right-click to uninstall the application

If you prefer you can watch a video here: https://www.youtube.com/watch?v=kopC_PiYSRs&t=6s

Manual Uninstall

This video will show you how to manually uninstall the software: https://www.youtube.com/watch?v=qaHDn_RdmRE

MAC

  1. Drag the application from your Applications folder to the trash folder and remove the app
  2. Delete the app system files :
    1. Open Finder
    2. At top of the screen, click on the menu Go
    3. Click on the 'Home' icon
    4. Open the 'Application Data' folder
    5. Move the IQUALIF folders to the trash

Linux

Through Software Manager

  1. Open Ubuntu Software manager.
  2. Click the Installed Tab and search for your installed application
  3. Click the Remove button next to your application. A pop-up message will appear “Are you sure you want to remove IQUALIF”. Click Remove.

Through Command Line

To uninstall IQUALIF, write the “apt-get” command in the command line

sudo apt-get --purge remove IQUALIF

Troubleshooting

If you encounter this issue while starting the application, follow the steps and try to restart the application

Troubleshooting Install

Possible issue :

  • I can't install
  • Computer reboot during install, solution is to install again
  • Software doesn't open after install

Windows

  1. Double click .exe on the downloaded IQUALIF executable after you have downloaded the software from the website. The installer opens and the Welcome screen appears.
  2. Click Next to continue.
  3. License Agreement screen appears. Accept and Click Next to continue.
  4. Installation Folder screen appears. Click Next to continue.
  5. The software installs, and the installation successful screen appears.
  6. Click Finish.
  7. On your Desktop, double-click the icon to launch the application

MAC

  1. Right-click the .pkg file that you have downloaded to your Mac operating system and click on open. The installer opens and the Welcome screen appears.
  2. Click Next to continue.
  3. License Agreement screen appears. Accept and Click Next to continue.
  4. Installation Folder screen appears. Click Next to continue.
  5. The software installs, and the installation successful screen appears.
  6. Click Finish.
  7. Locate the application folder and drag your IQUALIF to the application folder. Double-click the application to start IQUALIF.
  8. You can run software from your Application folder.

Linux

  • Check this link. Works on Java 8 with modified paths accordingly.
    • Run like this (check your java version) before run software (or make changes to environment file of your distribution):
      export JAVA_HOME=/usr/java/jre1.8.0_221-amd64/
      export PATH=$PATH:/usr/java/jre1.8.0_221-amd64/bin
  • Unpack via GUI or command line
    • Command-line (installing “IQUALIF Canada 41 White” as an example):
      1. Make new directory:
        mkdir -p "$HOME/Application Data/IQUALIF Canada 41 White" && cd "$_"
        • You MUST create this directory inside “$HOME/Application Data”, or you will get errors and software won't run.
      2. Copy downloaded archive to it:
        cp "/path/to/IQUALIF Canada 41 White.zip" .
      3. Unpack it:
        unzip "IQUALIF Canada 41 White.zip"
      4. Remove archive:
        rm "IQUALIF Canada 41 White.zip"

Troubleshooting Open

Windows

  1. Right click IQUALIF shortcut located on desktop
  2. Select Open with and search for installed Java
  3. Select Java and Tick always use this app to open .jar files
  4. Click Ok
  5. Re-start application to check if problem is fixed

If you could not find java in the list of installed programs, it is probably due to the reason that the Java was not installed with your application installation. Try to install it by

  1. Go to C drive and open Program Files (x86)
  2. Select IQUALIF folder
  3. Search for jre-8u31-windows-i586.exe setup file and double-click to install it
  4. Complete the installation steps
  5. Re-start IQUALIF application to check if the problem is resolved

MAC

  1. Open Finder App
  2. Click on the Go menu at the top of the screen and select Home
  3. Open the Application data and then IQUALIF folder
  4. Open l.jar file to start application

Error Message

Error Description
Invalid server response, please try again or contact us for further detail Invalid Server Response occurs occasionally at program start-up, activation of trial version/license, or refreshing a list of contacts. Possible Fixes for the error are: Try to reinstall the program, Check for software updates, Wait for the server to become available again
No data received, Invalid server response, please try again or contact us for further detail
Empty response, Invalid server response, please contact us for further detail
Internal Server Error, Invalid server response, please refresh the list or contact us for further detail
No data warning, Invalid server response, please refresh the list or contact us for further detail
Error, please try again or restart IQUALIF, contact us for more details The error occurs when the application is unable to start normally. Restart application to check if the issue is resolved
Error on program launch, Please restart IQUALIF or contact us for more details The error occurs when the system is unable to start normally. Restart application to check if the issue is resolved
Error, cannot save the setting, please contact us for more details The error occurs when the system is unable to automatically save user settings. Restart application to check if the issue is resolved
License already activated, please contact us to reactivate or get one at www.iqualif.comThe error occurs when you try to re-activate an application that is already activated
3 day Trial has expired. Please get a license at www.iqualif.com or contact us to keep using IQUALIF The error occurs when you try to use the application after your 3-day trial has expired
License expired, please contact us to reactivate or get one at www.iqualif.com The error occurs when you try to use the application after your IQUALIF license has expired
Cannot load language module, loading default language, please restart IQUALIF or contact us to fix it The error occurs when an application fails to load language. Restart application to check if the issue is resolved
Cannot load settings, loading default settings, please restart IQUALIF or contact us to fix it The error occurs when an application fails to load the settings screen. Restart application to check if the issue is resolved
Cannot display browser, notify us at www.iqualif.com or contact us for more details The error occurs when an application fails to load browser in Browser Mode search
email not sent, please check configuration or contact us for more details The error occurs when an application fails to send an email through the Contact Us screen. Check email configurations of your system and try again
Version limited to 50 contacts, activate the free trial version, or get a license on www.iqualif.com to use the full version of IQUALIF The error occurs when you try to search contacts after your trial version has expired. The application lets you retrieve results of 50 contacts only. Purchase the software to fix the problem
Import failed, please consult the help or contact us for more details Unsupported format, please contact support at contact@iqualif.com The error occurs when you try to upload a file format that is not supported by the application. File format for search with imported file is postcode;cities;streets. File format for IP obfuscation is 10.0.0.1:3126 or socks;10.0.0.1:3126;user;pass

Shortcut

  1. CTRL+0 : Use default behavior
  2. CTRL+1 : Try to use server 1
  3. CTRL+2 : Try to use server 2
  4. CTRL+3 : Try to use server 3
  5. CTRL+F : Fast search
  6. CTRL+I : Import a list of locations or categories from a file
  7. CTRL+P : Counter mode (only search first page)
  8. CTRL+Q : Quit software
  9. CTRL+R : Reset search
  10. CTRL+S : Save result to excel or csv
  11. CTRL+V : Reset software speed

Excel tutorial

Filter records

To delete records based on specific values in the excel sheet, open the worksheet and follow the linear steps illustrated below

Step 1

Select the header row and click on the ‘Filters’ option in Filters and Data Tab. You can use short-cut keys Ctrl+Shift+L keys to apply or remove the filter directly.

img

A dropdown img will appear as a downward-pointing triangle icon at the top-right of the cell. This will enable you to find and select records based on your search criteria. You can perform various operations like conditional formatting, deletion, or formulated calculations on filtered data.

img

Step 2

Click the filter icon on the target column. A pop up will appear. Select a relevant value from the list (in this case, it is ‘ILLE ROUSSE’) and Click ‘Ok’. For large datasets, it is recommended to uncheck ‘Select All’ and type the value in the Search bar to eliminate the need for manual search from the list.

img

To filter through the search bar, type the text in the search field and click ‘OK’

img

All relevant records will be extracted from data, as shown below

img

Step 3

Select rows by clicking the first record and dragging it towards the end of the sheet. The selected records will be highlighted in grey as shown below. Right-click on selection and click Delete Rows from pop up. Alternate keys to delete rows is Ctrl- . All selected rows will be deleted successfully from data.

img

After Deletion, use Ctrl+shift+L to remove filters.

1)
Yellow version only
2)
White version only
en/public.txt · Last modified: 2021/06/08 10:04 by admin

Page Tools